Performance Degradation
Incident Report for People.ai
Resolved
This incident has been resolved.
Posted May 26, 2021 - 16:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2021 - 16:06 PDT
Investigating
People.ai is currently experiencing degraded performance. You may experience longer than normal load times. As a result of this incident, our Activity API is also seeing elevated error rates. Our engineering team is aware of the issue and actively working to resolve it. Please stay tuned for updates.
Posted May 26, 2021 - 12:08 PDT
This incident affected: People.ai Web-Application, People.ai Analyze, Data Warehouse, and People.ai Metrics Services.