Performance Degradation

Incident Report for People.ai

Resolved

This incident has been resolved.
Posted Dec 15, 2020 - 09:22 PST

Update

We are continuing to monitor for any further issues.
Posted Dec 15, 2020 - 09:01 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 15, 2020 - 09:01 PST

Update

We are continuing to investigate this issue.
Posted Dec 15, 2020 - 08:19 PST

Investigating

People.ai is currently experiencing degraded performance. You may experience longer than normal load times. Our engineering team is aware of the issue and actively working to resolve it. Please stay tuned for updates.
Posted Dec 15, 2020 - 08:12 PST
This incident affected: People.ai Web-Application.