Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2026 - 00:00 PDT
Scheduled
We will be performing scheduled maintenance on core People.ai platform infrastructure to improve reliability and performance.
Potential Impact You will still be able to sign in and use most core People.ai functionality. During this maintenance window, some data processing features may be temporarily affected:
- Activity data synchronization may be delayed - Data updates may process more slowly than usual - Brief interruptions in real-time data processing (up to 10 minutes) - Occasionally return transient errors that are resolved by retrying
What We're Doing Our engineering team will be upgrading critical infrastructure components that support data processing and real-time activity capture. This work has been thoroughly tested and is designed to enhance platform stability and scalability.
We will monitor the platform closely throughout this maintenance activity and post updates here when work begins, as it progresses, and once it is complete.
Posted Mar 10, 2026 - 08:35 PDT
This scheduled maintenance affected: Salesforce Inbound Data Integration, Salesforce Outbound Data Integration, Data Warehouse, and Activity Intake APIs and Services.