Performance Degradation

Incident Report for People.ai

Resolved

This incident has been resolved.
Posted Nov 06, 2020 - 06:35 PST

Investigating

People.ai is currently experiencing degraded performance. You may experience longer than normal load times. Our engineering team is aware of the issue and actively working to resolve it. Please stay tuned for updates.
Posted Nov 06, 2020 - 06:20 PST
This incident affected: People.ai Web-Application.