Performance Degradation
Incident Report for People.ai
Resolved
This incident is now resolved.
Posted May 22, 2021 - 09:43 PDT
Monitoring
The team has implemented a fix and monitoring the environment.
Posted May 22, 2021 - 09:02 PDT
Identified
The team has identified the root cause and working on a fix.
Posted May 22, 2021 - 08:02 PDT
Investigating
People.ai is currently experiencing degraded performance. You may experience longer than normal load times. Our engineering team is aware of the issue and actively working to resolve it. Please stay tuned for updates.
Posted May 22, 2021 - 07:09 PDT
This incident affected: People.ai Web-Application, People.ai Analyze, Salesforce Inbound Data Integration, Salesforce Outbound Data Integration, Data Warehouse, Activity Intake APIs and Services, and People.ai Metrics Services.